IS355 – Working with Spreadsheets Using Excel 2010

October 2013

Book online at: rhul.ac.uk/it/training
or scan QR code
Self-Study packs also available
# Table of Contents

- **Files Required and Introduction** ................................................................. 2
- **Accessing the IT Training Exercise Files from your Own PC/Laptop** ............... 3
- **The Excel Screen** .......................................................................................... 4
- **Browsing for Help** ......................................................................................... 5
- **Opening an Existing Workbook** ................................................................. 6
- **Working with Excel's Document Versions** .................................................. 7
- **Understanding Cells, Rows, and Columns** .................................................. 8
- **Typing Simple Formulas in a Worksheet** .................................................... 9
- **Using the Fill Handle** ................................................................................... 10
- **Formulas that Subtract, Multiply and Divide** ............................................. 11
- **Using the AutoSum Button** .......................................................................... 12
- **Calculating an Average** ............................................................................... 13
- **Using the IF (Logical) Function** .................................................................. 14
- **Aligning to the Centre** ............................................................................... 15
- **Undoing and Redoing Operations** ............................................................... 16
- **Rotating Text** .............................................................................................. 17
- **Merging and Centering** ................................................................................ 18
- **Inserting and Deleting Rows & Columns** .................................................... 19
- **Adjust Column Widths Manually & with Autofit** ....................................... 20
- **Adjust Row Heights Manually & with Autofit** ........................................... 21
- **Hiding Rows and Columns** ........................................................................... 22
- **Freezing Rows and Columns** ....................................................................... 23
- **Changing Fonts** ............................................................................................ 24
- **Making Cells Bold & Italic** .......................................................................... 25
- **Changing Font Colours** .............................................................................. 26
- **Applying Borders** ....................................................................................... 27
- **Changing Background Colours** .................................................................... 28
- **Creating Absolute References (1)** ................................................................ 29
- **Creating Absolute References (2)** .............................................................. 30
- **Inserting, Deleting, and Renaming Worksheets** ......................................... 31
- **Moving and Copying a Worksheet** ............................................................... 32
- **Finding and Replacing Text** ......................................................................... 33
- **Understanding Cell Error Values** ................................................................ 34
- **Sorting Data into Order** ............................................................................... 35
- **Compare Workbooks Side by Side** ............................................................. 36
- **Setting Rows as Repeating Print Titles** ....................................................... 37
- **Performing a Print** ....................................................................................... 38
- **Closing a Workbook & Exiting from Excel** ............................................... 39
- **Session Evaluation** ...................................................................................... 40

---

*These session notes are available in alternative formats on request. For further information please contact Chris Horton in Computer Centre Room 108.*

(01784 41 4025, c.horton@rhul.ac.uk)
FILES REQUIRED AND INTRODUCTION

A. Files Required

The files required for this session are:

<table>
<thead>
<tr>
<th>File Name</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Global Enterprises.xlsx</td>
<td>R:\IT Training\General\New Global Enterprises.xlsx</td>
</tr>
</tbody>
</table>

The (R:) drive, from which this file can be accessed, is available on all Open Access PCs. This can also be mapped on your own computer; details are given on the next page.

B. Introduction

This session looks at Microsoft Excel, a spreadsheet package which is used for working with numerical data. A spreadsheet is a powerful tool which can be used to store, manipulate, calculate and analyse data such as numbers, text and formulae. In its simplest form, a spreadsheet consists of a grid into which you can enter numbers, text and formulae so that you can perform calculations quickly and easily.

In the session you will be introduced to the concepts, important issues and basic use of the Excel spreadsheet application. By the end of the session you will be able to enter and manipulate data and simple formulae in a spreadsheet, along with being able to use some of the arithmetic operations and statistical functions that are incorporated in Excel.

C. Starting Excel 2010 in an open-access PC Lab

Follow these steps:

1. Click on Start at the bottom left of the screen on the Task Bar.

ACCESSING THE IT TRAINING EXERCISE FILES FROM YOUR OWN PC/LAPTOP

In order to access the files required to complete many of the IT Training exercises you need to access a shared drive, referred to as the (R:) drive in the notes. These instructions give details on how to connect to this drive, for example from your home, along with details on how you can also set up access to your (Y:) drive.

Important: If your PC already has an (R:) drive/(Y:) drive you will need to select a different letter in the following instructions.

Follow these steps:

Note: If using a Mac, instructions on setting up Campus Anywhere (VPN) can be found at: http://www.rhul.ac.uk/IT/CampusAnywhere/
Instructions on mapping to the (R:) drive and (Y:) drive can be found at: http://www.rhul.ac.uk/it/faq/itfaqs/mac/mapnetworkdrive.aspx

If working on Campus ensure that you are connected to CampusNet.

OR

1 If working off Campus ensure that you are connected to the Internet and that you have connected to Campus Anywhere (VPN).

Note: To obtain instructions on how to set up Campus Anywhere (VPN) visit: http://www.rhul.ac.uk/IT/CampusAnywhere/

Display My Computer or Computer:
Press the Windows key at the right of the keyboard and with it still depressed press E on the keyboard.

OR

Click on Start and then click on Computer at the right of the Start menu.

To map to the (R:) drive:
Click on Tools.

Select Map network drive to open the Map Network Drive dialogue box.
Click on the drop-down arrow to the right of the Drive: panel and select R: (or any letter of your choice if that already has an entry, and so already allocated).

In the Folder: panel enter the mapping for the (R:) which is:
\ourdata.rhul.ac.uk\teaching\PCLabs

Ensure that the Reconnect at logon box displays a tick mark. If it does not, click within it so that it displays one.

5 Click on [Finish] to complete the setting up.
You should now be able to see the (R:) drive containing the IT Training files.

To map to your (Y:) drive:
You can map to your (Y:) drive as covered in steps 3, 4 & 5 but taking note of the following:

a) If your PC already has a (Y:) drive you will need to select a different letter in step 3.
b) In step 4 the path that you must enter is: \mydata.rhul.ac.uk\home\

Note: When accessing these drives you may be prompted for your username and password.

If this occurs you must prefix your username with cc\ For example, if your username is zhaa666 then you must enter cc\zhaa666

8 When finished close the My Computer dialogue box by clicking on its Close button.
If a My Computer window is still displaying also close it by clicking on its Close button.
THE EXCEL SCREEN

Once you know your way around the Excel screen you’ll find it much easier to use. The Excel screen is made up of a number of different elements. Some, like the Ribbon and Status Bar, may be familiar to you if you have already used Word 2010 or PowerPoint 2010. Do remember that many options are the same, e.g. saving, the Format Painter, and Find and Replace.

1. **The Ribbon** is the tabbed band that appears across the top of the window. It is the command control centre of Excel 2010. You use the tabs on the Ribbon to access commands which have been categorised into groups (the Font group is circled above).

2. The **Formula bar** is where you can view and edit the contents of a cell, e.g. text, numbers or formulae.

3. The **Active Cell** is where text, numbers, and formulas will appear when you start typing.

4. The **Worksheet** is like an electronic piece of paper ruled into columns and rows. The worksheet is where you type numbers, letters, and formulas to perform calculations. Notice that columns are headed using letters of the alphabet (A, B, C, etc) while rows are designated using numbers down the left side.

5. The **Status bar** appears across the bottom of the window and displays useful information about what is happening in the worksheet. The View buttons and the Zoom Slider at the right of the Status bar are used to change the view or to increase or decrease the zoom ratio of your worksheet.
**BROWSING FOR HELP**

When you first open the **Excel Help** window, no matter how you access it, you are presented with a series of topics that you can open and read through.

The Excel Help window comes with a series of buttons that you can use to navigate Help topics, moving backwards and forwards between them as you like.

---

**Follow these steps:**

1. Click on the Help button at the top-right of the Ribbon to display the Excel Help window.

2. In addition to the Search box at the top of the window, which enables search terms to be entered for the help you need, a number of links are included that cover the most commonly requested help topics.

3. To demonstrate the links click on **Worksheets** towards the bottom right of the Help window to see the help about this topic.

4. Click on the **Editing data** link. This takes you to specific help about this topic.

5. View the help options available.

6. When you have finished click on the Close button at the top-right to close the Excel Help window.
OPENING AN EXISTING WORKBOOK

Although there are a number of different ways to open an existing workbook; you can use the File tab or double-click directly on an icon of the file. However, perhaps the best and simplest way to do it is from within Excel itself, using the Open dialogue box. The Open dialogue box has tools that help you to identify file types and location.

Follow these steps:

1. Click on the File tab at the top-left of the window. Then select Open to display the Open dialogue box.
2. If necessary scroll down in the left-hand panel to display the list of available drives. Click on the (R:) drive in the list to select the drive and display its contents in the right-hand panel.
3. In the right-hand panel double-click on the IT Training folder. Then double-click on the General folder to display its contents. This is the folder where the session’s file can be found.
5. We now need to save this workbook to your (Y:) drive. To do this, first click on the File tab at the top-left of the screen. Then select [Save As] to open the Save As dialogue box.
6. If necessary scroll down in the left-hand panel to display the list of available drives. Click on your (Y:) drive in the list to select the drive and display its contents in the right-hand panel.
7. If you wish to save the document to your IT Skills folder, which was automatically created for training sessions, navigate to this in the right-hand panel. Then double-click on it to select it.
8. Click on [Save] to save the workbook to the IT Skills folder on your (Y:) drive. You can now begin to make changes to the Workbook.
**WORKING WITH EXCEL’S DOCUMENT VERSIONS**

Excel's **File** tab (also called the Backstage view) replaces the Office Button and File menu of previous versions. One new option under the **File** tab is the **Info** button, which includes a **Versions** option.

It is recommended that you take great care if using the **Versions** option, as it is easily possible to replace the current version of your document with a previous one!

**Follow these steps:**

1. We will briefly examine this new Versions option.
2. To begin click on the **File** tab at the top-left of the screen. Then select **Info** to display information about the document you have open.
3. On the open-access PCs, once you start working on this document Excel will take regular backup copies of the document in case the PC freezes or Word crashes.

   **Note:** These backups are taken every 10 minutes by default, although this can be changed if you wish. Also, it should not be assumed that this option **IS** enabled.

4. (To check **File** tab > **options** > **Save** > ensure **Save AutoRecover information every 10 minutes** and **Keep the last autosaved version if I close without saving** ARE ticked )
5. These incremental backups are then displayed under the **Versions** heading.

   Although there may be occasions where it is useful to go back to a previous version, you need to take great care when doing this.

6. This is because if a previous version is opened and the **Restore** button on the yellow band that appears above the document area is clicked you will replace the current (latest) version of your document with the earlier version, hence potentially losing work!

   Therefore it **is strongly recommended** that this facility is used only when absolutely necessary, and that you separately protect your work by saving frequently and changing the filename regularly.

7. When you have finished click on the **Home** tab at the left of the **Ribbon**.
UNDERSTANDING CELLS, ROWS, AND COLUMNS

An Excel spreadsheet is defined by rows and columns. Excel is defined this way to better locate cells. Cells are used for inserting information in a spreadsheet. A cell is first identified by its column letter then by its row number. Therefore, cell E2 is under column E and in row 2. Additionally, an Excel file, or workbook, may contain a number of such spreadsheets.

Follow these steps:

1. First ensure that you are viewing the Weekly Sales spreadsheet by clicking on the Weekly Sales tab at the bottom-left of the screen to display it (illustration below).
   
   The basic unit of a worksheet is a cell (where column and row intersect) in which you store data.

2. **Rows** are numbered in ascending order 1 to 100 etc. **Columns** are letters in ascending order A to Z etc. A particular cell in the worksheet is identified by its cell address, that is, its column and row position.

   Now click on cell A20 in the worksheet.

   This is the first column on the left and twenty rows down from the top of the worksheet.

   When it is clicked on it becomes the active cell, and is highlighted by a thick border.

3. With cell A20 selected, type the heading **Total** on the keyboard.

4. Click on the right arrow key on the bottom-right of the keyboard to select cell B20. Then type **156365**.

5. Press the [Enter] key at the right of the keyboard to accept the entry.

   **Note:** Excel is very good at doing calculations! So entering a total in this way should be avoided unless there is NO alternative – let Excel do it for you.

   Additionally, entering a total in this way, as a hard number, is prone to mistakes (as in this case – check it), and the number does not automatically update if changes are made to the underlying values.

   Don’t forget to frequently save your workbooks to make sure your information is not lost. The Save button is located on the Quick Access Toolbar at the top-left of the screen. It is recommended that you Save your work at least every 10 minutes.
**Typing Simple Formulas in a Worksheet**

The whole idea behind Excel is to get it to perform calculations. In order for it to do this you need to type formulas in the worksheet. Usually these formulas reference existing numbers, or even other formulas already in the worksheet, using the cell addresses of these numbers rather than the actual value in them. Formulas must be typed beginning with an equals sign (=).

**Follow these steps:**

1. We will now consider several different ways of performing calculations. To begin, ensure you are still viewing the Weekly Sales spreadsheet.

2. Click on cell G7 to make this the active cell.

3. Type \(=B7+C7+D7+E7+F7\) and examine what is happening on the screen.

   Press the [Enter] key at the right of the keyboard to complete the formula and move to the next cell.

4. Notice that a calculation has now been performed.

   This is because we entered a formula in G7 that says “add the values in cells B7 to F7 and show them here”.

   Make sure that G8 is the active cell.

   Another method of adding cell values together is by using the **Sum** function.

   A function is a small programme designed to carry out a particular task, in this case to add some numbers together.

   Type \(=\text{SUM}(B8:F8)\)

   Then press the [Enter] key.

   The B8:F8 tells Excel to include all cells (the range) from B8 to F8.

   Click on cell G8 again.

   You should see the cell now displays the result of the calculation, (183,351).

   Now view the **Formula bar**, found below the **Ribbon** towards the top of the window (illustration below).

   This shows the formula that produced the result displayed in cell G8. You can select a cell and then type or edit a formula in the **Formula bar**, as well as directly in the cell.

   **Note:** When entering a formula you must remember to type the equals sign (=) first to let Excel know it is a formula you are typing in.

   9. Click on **Save** to save the changes you have made.
Using the Fill Handle

A series refers to a sequence of ordered entries in adjacent cells, such as the days of the week or months of the year. The fill technique can be used to create these in a worksheet for you, reducing the amount of time taken for data entry, and ensuring that the spelling is correct. Excel provides days and months as special built-in series that you can access. The Fill Handle is also very useful in copying formulae.

Follow these steps:

1. Here we are going to learn about using the fill handle to copy a series of data, like the days of the week, a number sequence, or a formula, into adjacent cells. Before starting make sure you are viewing the Weekly Sales spreadsheet.

2. Click on cell A7 and type Tuesday. This will be the beginning of a series with the days of the week. Instead of typing every day we will use the fill handle to insert the rest of the week into our spreadsheet.

3. With cell A7 still selected move the mouse pointer to the bottom-right corner of the cell (illustration below) until the mouse pointer appears as a thin black cross. Drag the mouse pointer down to cell A10.

4. Excel will fill the range with the rest of the days in the work week, Wednesday, Thursday, and Friday.

5. To practise this skill again click on cell A15 and type Saturday. Then use the fill handle to drag to cell A16. The day Sunday should now appear in cell A16.

6. The fill handle can also be used to fill cells on the same row. To do this, click on cell B5 and type Week 1 to insert a column heading for column B. Use the fill handle at the bottom-right of cell B5 and drag to cell F5 to create headings displaying the weeks.

7. The fill handle can also be used to copy formulae down a column or across a row, which saves having to create it individually for each cell. To practise this we will now copy the formula in cell G8 down to cells G9 and G10.

8. Start by clicking on cell G8. Then move the mouse pointer to the bottom-right corner of the cell until the mouse pointer appears as a thin black cross. Drag the mouse pointer down to cell G10. Excel will fill the range with the formulae to enable cells G9 and G10 to display the missing totals.

9. Click on Save to save the changes you have made.
FORMULAS THAT SUBTRACT, MULTIPLY AND DIVIDE

Basic formulas involve the same types of arithmetical operations within the one calculation. That is, addition, subtraction, multiplication, or division. You can mix these operations within the one formula as much and as often as you need. However, you should always keep in mind the basic rules of BODMAS (mathematical order of operations), especially where division is concerned.

Follow these steps:

1. Click on cell I12. This is where we will begin calculating different mathematic equations.

   To consider subtraction enter a formula to show the possible midweek income had it been a 4 week month.

2. Begin by typing = to start the formula.
   Then click on G12 and type a hyphen (-), which stands for subtraction, and then click on cell F12.

3. Press the [Enter] key at the right of the keyboard to complete the formula.
   We have now subtracted the value in cell F12 from the value in cell G12.

4. Click on cell I7.
   To consider how to multiply in Excel enter a formula to calculate what 5 times the Week 5 Tuesday midweek figure equates to.
   Begin by typing = to start the formula.
   Then click on F7
   Then type * (which stands for multiplication) and enter 5 on the keyboard.

5. Press the [Enter] key at the right of the keyboard to complete the formula.
   We have now multiplied the value in cell F7 by 5.

6. Ensure that cell I8 is selected
   Then type =
   Click on cell G8 then type a forward slash (/), which is Excel’s division sign, and then click on cell D8.

7. Press the [Enter] key to complete the formula.
   This means that you wish to divide the contents of cell G8 by the contents of cell D8.

8. Click on Save to save the changes you have made.
**USING THE AUTO SUM BUTTON**

The AutoSum button enables you to easily add together the contents of a range of cells. Wherever possible, Excel suggests the cells you wish to sum, however it is easy to change the suggestion by clicking and dragging across the cells you do require. **Remember:** you can select cells that are not alongside each other by holding down the [Ctrl] key on the keyboard and clicking on the required cells.

**Follow these steps:**

1. In addition to creating formulae to add together the values of cells, you can also use the AutoSum button, which we will now examine by adding together the cells B15 to F15. Before starting, make sure you are viewing the **Weekly Sales** spreadsheet.
   
   Click on cell **G15** which is where the total for cells **B15** to **F15** is to appear.

2. Make sure you are viewing the **Home** tab on the **Ribbon**.
   
   Then click on the **AutoSum** button (illustration below).
   
   **Note:** click on the button, NOT the drop-down arrow to its right.

   Where possible, Excel offers a suggested range to be summed, as indicated by the moving border around cells **B15** to **F15**.

3. If you wish to use the suggested range you just need to press [Enter] to accept it.
   
   Alternatively, if you wish to use a different range you just click and drag across the required cells.

4. When the required cells are selected, as is the case here, press the [Enter] key at the right of the keyboard to complete the calculation.

5. We also need to total Cells **B16** to **F16**.
   
   We could use the fill handle to copy the formula in cell **G15** down to **G16**, however in this case we will do this using the AutoSum button again.

6. Click on cell **G16**, which is where the total for cells **B16** to **F16** is to appear.
   
   Make sure you are viewing the **Home** tab on the **Ribbon**.
   
   Then click on the **AutoSum** button (NOT the drop-down arrow to its right).

7. Excel suggests the range to be summed is **B16** to **F16**, which is correct, so press the [Enter] key at the right of the keyboard to complete the calculation.

8. Click on **Save** to save the changes you have made.
CALCULATING AN AVERAGE

The **AVERAGE** function allows you to average the values in a range of cells. It is written in much the same way as the **SUM** function, for example:

\[ \text{=AVERAGE(range of cells to average).} \]

The average function can be applied using the **Functions Wizard**, a part of Excel that steps you through the process of creating a function or you can type it in yourself if you are comfortable with it.

Follow these steps:

1. Before starting click on cell **I9** on the **Weekly Sales** spreadsheet. This is where we will calculate the average sales amount for **Thursday** sales.

2. We will begin by using the **Functions Wizard** to create the average.

3. Click on **AVERAGE** in the **Select a function:** list. Then click on **[OK]** to display the **Function Arguments** dialogue box.

4. The system may have a range already selected for you. We will select a different range. To do that, click on the **Range Selector** tool for **Number1** (illustration below) to roll up the wizard.

5. Then click and drag across cells **B9** to **F9** to select the range **B9:F9**.

6. Press the **[Enter]** key at the right of the keyboard to complete the range specifications. Then click on **[OK]** to complete the process.

7. First click on **cell I10** to select where we want the result to display. Then click on the **AutoSum button** options to create the average for Fridays.

8. Next click on the drop-down arrow to the right of the **AutoSum button** on the **Editing group** (illustration below) at the right of the **Ribbon**. Then select **Average**.

9. We will now use the **AutoSum button** options to create the average.

10. First click on **cell I10** to select where we want the result to display. Then click on the **Home** tab at the left of the **Ribbon**.

11. Next click on the drop-down arrow to the right of the **AutoSum button** on the **Editing group** (illustration below) at the right of the **Ribbon**. Then select **Average**.

12. The system may have a range already selected for you. We will select a different range.

13. To do that, click on **cell B10**, then click and drag across to cell **F10**. When you have finished press the **[Enter]** key to complete the formula.

14. Click on **Save** to save the changes you have made.
Using the IF (Logical) Function

The IF function (also called the Logical function) enables a calculation to be performed, or one or more words inserted into a cell, based on the result of a test. For example, a test can be performed on a cell to ascertain whether it is within a certain range. If it IS the cell where the IF function has been entered could display a confirmation word (e.g. True) or perform a calculation. Similarly, if the condition is NOT within the tested range a suitable word or words could be displayed (e.g. untrue) or calculation performed to indicate this.

Follow these steps:

1. We will now use the IF function to indicate in cell J12 the level of Midweek sales: if the value in cell G12 is above 850,000 (the test income figure) then ‘Is True’ will be displayed in cell J12. Conversely, if the value in cell G12 is below 850,000 then cell J12 displays ‘Is False’. To do this we will use the Functions wizard.

2. Begin by clicking in cell J12, which is where the IF function is to be inserted.

3. To access the Functions Wizard click on the Insert Function button found below and towards the left of the Ribbon (illustration below).

4. This will display the Insert Function dialogue box. Remember: This can also be accessed by clicking on the drop-down arrow to the right of the AutoSum button.

5. Click on the down-arrow to the right of the Or select a category: panel and select Logical.

6. Then select the IF option in the Select a function: panel Click on [OK ] to display the Function Arguments dialogue box.

7. Click in the Logical test panel.

8. We want our test to reference cell G12 so begin by clicking on G12.

9. We now need to ascertain whether this is greater than 850000 (the accepted income figure) so after the cell reference enter >850000 so that the Logical test panel displays G12>850000

In the Value-if-true panel enter what is to be displayed if G12 IS greater than 850000, in this case we will display Is True, so enter Is True

Similarly, in the Value-if-false panel enter what is to be displayed if G12 ISN’T > 850000, in this case enter Is False

Then click on [OK] to close the dialogue box.

Cell J12 should now display Is True as the value in cell G12 is greater than 850000.

To test your IF function change the value in G12 to 315000; cell G12 should display Is False because the value in cell G12 is now less than 850000.

Click on Undo in the Quick Access Toolbar at the top-left of the window to undo the last change.

8. Click on Save to save the changes you have made.
ALIGNING TO THE CENTRE

For visual effect it is sometimes useful to align text to the centre of a cell. Placing text in the centre means that there is essentially a “corridor” of space left either side which helps improve readability.

Although numbers can also be centre aligned it is frequently better to leave them right aligned, as they are set to do by default.

Follow these steps:

1. Make sure you are still viewing the Weekly Sales spreadsheet.

Before you begin notice that the numbers in the cells are right aligned (e.g. cell B7) and text is left aligned (e.g. cell A7).

2. Excel does this to indicate the type of data in a cell, i.e. numbers are right aligned to indicate that calculations can be performed on them (unless they have been manually formatted).

3. We will centre align the Midweek heading.

So begin by clicking in cell A6 in the worksheet to select it.

4. Click on the Home tab at the left of the Ribbon.

Next click on the Centre command (illustration below) in the Alignment group near the centre of the Ribbon.

The text in cell A6 will now align to the centre of the cell.

5. Click on cell A7 and then drag down to cell A18 to select the range A7 to A18.

A quick way to describe this range is to type A7:A18.

6. Click the Centre command in the Alignment group in the centre of the Ribbon again to centre the text in these cells.

7. Click on Save to save the changes you have made.
UNDONE AND REDOING OPERATIONS

Excel provides you with **Undo** and **Redo** commands on the **Quick Access Toolbar** which allow you to undo operations such as deletions and then if necessary redo them again. **Undo** is great to have around for those times when you’ve accidentally changed or deleted something you wish you hadn’t. As long as you haven’t saved or closed the workbook you’ll be able to undo most operations.

**Follow these steps:**

1. Before starting we will select the range **B5:B20**. To do this click on cell **B5** and then click and drag down to cell **B20**.
2. Click on the **Home** tab at the left of the **Ribbon**. Then click on the **Delete** command in the **Cells** group found towards the right of the **Ribbon** to delete the selected range.
3. Repeat **step 2** to delete range **D5:D8**.
4. Click on **Undo** in the **Quick Access Toolbar** at the top-left of the window twice to undo each of the deletions. Excel stores each operation and you can undo them in the opposite sequence to which they were originally performed. This is like stepping back one step at a time through previous operations.
5. Click on **Redo** in the **Quick Access Toolbar** at the top-left of the window twice to step forward through the operations again. This allows you to change your document back to how it was before you undid an action. That is, you can redo what you already have done.
6. Click on **Undo** in the **Quick Access Toolbar** twice to return the document to how it was before deleting anything.
7. Click on **Save** to save the changes you have made.

---

**Health Services**

<table>
<thead>
<tr>
<th>Week</th>
<th>Week 1</th>
<th>Week 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Midweek</td>
<td>21,412</td>
<td>25,942</td>
</tr>
<tr>
<td>Tuesday</td>
<td>20,824</td>
<td>31,286</td>
</tr>
<tr>
<td>Wednesday</td>
<td>20,722</td>
<td>29,782</td>
</tr>
<tr>
<td>Thursday</td>
<td>49,254</td>
<td>64,750</td>
</tr>
<tr>
<td>Friday</td>
<td>112,212</td>
<td>151,762</td>
</tr>
</tbody>
</table>

**Global Enterprises**

<table>
<thead>
<tr>
<th>Week 2</th>
<th>Week 3</th>
<th>Week 4</th>
<th>Week 5</th>
</tr>
</thead>
<tbody>
<tr>
<td>25,942</td>
<td>24,944</td>
<td>53,624</td>
<td>35,241</td>
</tr>
<tr>
<td>31,288</td>
<td>37,456</td>
<td>48,509</td>
<td>45,214</td>
</tr>
<tr>
<td>29,782</td>
<td>35,963</td>
<td>35,128</td>
<td>75,963</td>
</tr>
<tr>
<td>64,750</td>
<td>125,811</td>
<td>75,809</td>
<td>35,429</td>
</tr>
</tbody>
</table>

| 151,762 | 224,174 | 203,182 | 171,847 | 756 |

| 26,760 | 75,256 | 124,512 | 96,583 | 32 |
| 19,874 | 35,842 | 25,634 | 84,212 | 163 |
| 46,634 | 111,098 | | | 488 |

| 302321 | | | | |
**ROTATING TEXT**

Excel also enables you to change the orientation of your data – this is known as text rotation. You may, for example, have a worksheet that has many columns of values that need to be squeezed onto one page. Rotating the column headings will allow you to retain narrow columns and still have longish and descriptive headings for each column.

Follow these steps:

1. We will rotate the text in cell B5, so click in cell B5 of the current worksheet to select it.
   - Click on the Home tab at the left of the Ribbon.
   - Next click on the Orientation command (illustration below) in the Alignment group towards the centre of the Ribbon.
   - Select Angle Counterclockwise to angle the cell at 45°.

2. Now set the rotation in the opposite direction by clicking on the Orientation command and selecting Angle Clockwise.

3. Now set the rotation of cells C5 to G5.
   - To do this click on cell C5 and then drag across to cell G5.

4. Click on the Orientation command
   - Then select Angle Clockwise to set the rotation of the remaining headings.

5. Click on Save to save the changes you have made.
MERGING AND CENTRING

Spreadsheets are just as susceptible to fads as virtually everything else in life! Over the years it has become fashionable to centre the heading over the relevant data. Trying to do this manually without the **Merge & Centre** command is tedious to say the least.

Follow these steps:

1. Click in cell A1 which contains the main heading of the worksheet. We are going to centre this across the worksheet’s main columns.
2. To begin this click and drag from cell A1 to cell G1, to select the range A1:G1.
3. Click on the **Home** tab at the left of the **Ribbon**.
4. Next click on the **Merge & Centre** button (illustration below) in the **Alignment** group found towards the centre of the **Ribbon**.
5. This will centre the heading within the selected range and make A1:G1 a single cell.
6. We will now centre the subheading **Health Services** across cells A3 to B3.
7. So to begin click on cell A3 and drag across to cell B3 so that the range A3:B3 is selected.
8. Click on the **Merge & Centre** button to centre the subheading across the range.
9. Click on **Save** to save the changes you have made.
INSERTING AND DELETING ROWS & COLUMNS

The **Insert** command can be used to insert entire rows and columns, pushing the data in the cells below the new row or to the right of the new column. Also you can delete rows and columns which will move data up a row or to the next column to the left.

Follow these steps:

1. We will begin by creating a new row 10.
   So to begin click on the row header number for **row 10** to select the row.
   Click on the **Home** tab at the left of the **Ribbon**.
   Next click on the drop-down arrow for the **Insert** command in the **Cells** group at the right of the **Ribbon**.
2. Select **Insert Sheet Rows** from the menu that appears to insert a row above the one we selected.
   You should notice that a new **row 10** has been inserted and the data in the previous one is now in **row 11**.
3. Similarly, we will insert a new column C.
   So to begin click on the column header letter for **column C** to select the entire column.
   Click on the drop-down arrow for the **Insert** command in the **Cells** group at the right of the **Ribbon**.
4. Select **Insert Sheet Columns** from the menu that appears to insert a column to the left of the one we selected.
   So now there is a new column **C** and the data in the previous one is now in **column D**.
5. To delete the column we just added, click on the column header letter for **column C** to select it.
   Next click on the **Delete** command located at the right of the **Ribbon** in the **Cells** group.
   The column will be removed and data for **column D** will now be moved to the left.
6. Similarly, to delete **row 10** click on the row header number for **row 10** to select it.
   Next click on the drop-down arrow for the **Delete** command located at the right of the **Ribbon** in the **Cells** group.
   Select **Delete Sheet Rows** from the menu that appears to remove the row.
   The data for **row 11** will now be moved up into **row 10**.
7. Click on **Save** to save the changes you have made.
iddanefeudael Provided Column Widths Manually & with Autofit

The easiest and most visual ways to adjust column widths are either drag the column border either left or right until the desired width has been obtained or simply double-click on the border to create an autofit. An autofit is when a column adjusts itself to the size of its largest cell in the column.

Follow these steps:

1. Before starting view the Revenue worksheet by clicking on its tab on the bottom-left of the document.

   We will now adjust the column width of column A.

2. To begin move the mouse pointer to the border between the column A and B headings towards the top-left of the spreadsheet until the mouse pointer changes to a double arrow.

3. Double-click to perform an autofit. An autofit works by adjusting the column width for the widest data entry in that column. In this case, autofit has probably made column A a suitable width.

   However, if autofit does not make the width a suitable size you can do this manually:

   Move the mouse pointer to the border between columns A and B so that the mouse pointer changes to a double arrow.

   Hold down the left mouse button and drag it to the left or right until column A is a suitable width.

4. Click on Save to save the changes you have made.

---

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Alphoneus Global Enterprises</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Annual Revenue 2009</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>London</td>
<td>Dublin</td>
<td>Melbourne</td>
<td>New York</td>
<td>Total</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>1st Quarter</td>
<td>January</td>
<td>week 1</td>
<td>241558</td>
<td>355010</td>
<td>342524</td>
</tr>
<tr>
<td>4</td>
<td>week 2</td>
<td>234654</td>
<td>340940</td>
<td>327441</td>
<td>325807</td>
<td>123923</td>
</tr>
<tr>
<td>5</td>
<td>week 3</td>
<td>315976</td>
<td>464100</td>
<td>446937</td>
<td>458937</td>
<td>1692623</td>
</tr>
</tbody>
</table>

---

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Alphoneus Global Enterprises</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Annual Revenue 2009</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>London</td>
<td>Dublin</td>
<td>Melbourne</td>
<td>New York</td>
<td>Total</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>1st Quarter</td>
<td>January</td>
<td>week 1</td>
<td>241558</td>
<td>355010</td>
<td>342524</td>
</tr>
<tr>
<td>4</td>
<td>week 2</td>
<td>234654</td>
<td>340940</td>
<td>327441</td>
<td>325807</td>
<td>123923</td>
</tr>
<tr>
<td>5</td>
<td>week 3</td>
<td>315976</td>
<td>464100</td>
<td>446937</td>
<td>458937</td>
<td>1692623</td>
</tr>
</tbody>
</table>
ADJUST ROW HEIGHTS MANUALLY & WITH AUTOFIT

The height of rows will vary automatically depending upon the size and type of font that you choose. You can also elect to increase or decrease row height yourself. The easiest way to adjust the height of a row is by dragging the row borders with the mouse. You can also perform an **autofit** by double clicking on the border between rows.

**Follow these steps:**

1. Move the mouse pointer to the border between rows 1 and 2 until the mouse pointer changes to show **double arrows**.
2. Hold down the left mouse button and drag the row **down** until the sizing box is approximately **80**. The sizing box is a small text box that will appear by your mouse pointer.
3. Move the mouse pointer to the border between rows 1 and 2 again and when the arrow changes to **double arrows** double-click to perform an **autofit**.
4. Click on **Save** to save the changes you have made.

---

![Spreadsheet](image.png)
HIDING ROWS AND COLUMNS

Sometimes worksheets include data that may be of a sensitive, personal, or confidential nature. A typical example may be employee pay rates. The problem with having this data in a worksheet or workbook is, for example, that it can be easily read from the screen by passers by. Excel allows you to hide columns and rows from view, but still retain the content for performing calculations.

Follow these steps:

1. Before starting view the Weekly Sales worksheet by clicking on its tab on the bottom-left of the document.

2. We will begin by hiding column I, the Analysis column. Click on the column heading letter for column I to select the column.

3. Click on the Home tab at the left of the Ribbon. Next click on the Format command (illustration below) in the Cells group found at the right of the Ribbon. A format menu will appear. In the menu that displays select Hide & Unhide under the Visibility heading. Then select Hide Columns. Notice that column I no longer displays, and that the formulas in the spreadsheet are not affected.

4. Similarly, we will hide the Subtotals for Midweek and the blank row below it. So click on the row heading number for row 12. Then click and drag down to row 13 so that both rows 12 and 13 are selected. Click on the Format command in the Cells group at the right of the Ribbon. Select Hide & Unhide under the Visibility heading. Then select Hide Rows in the list that appears. The Subtotals are no longer displayed in the spreadsheet because rows 12 and 13 are now hidden.

5. To show the hidden rows again you need to first select the rows around the hidden rows. So to do this click on the row heading number for row 11, and drag down to the row heading number for row 14. Redisplay the hidden rows by clicking on the Format command in the Cells group at the right of the Ribbon, Selecting Hide & Unhide under the Visibility heading. Then select Unhide Rows.

6. To redisplay the hidden column, drag across the column headings H and J to select them. Then click on the Format command in the Cells group at the right of the Ribbon. Select Hide & Unhide under the Visibility heading and select Unhide Columns.
FREEZING ROWS AND COLUMNS

Rows or columns are sometimes used as headings. Sometimes rows and columns have so much information that you have to use the scroll bar at the right of the screen to view all the text in the spreadsheet. When doing this you may no longer be able to view any headings because you have scrolled past the heading column or row. To combat the issue of not knowing what the headings are when looking through the spreadsheet, you can freeze the headings so they always appear.

Follow these steps:

Before starting display the Revenue worksheet by clicking on the Revenue tab.

1. If you scroll down the worksheet you will find that the locations heading (London, Dublin etc.) is lost. Similarly, if you scroll to the right the months headings (January, February etc.) are lost.
   
2. We will freeze row 4 so the locations heading always display.
   
   Click on cell A5, as the rule for freezing panes is that you always click on the cell below the row to be frozen.
   
   As a result rows 1 to 4 will now be frozen and remain on the spreadsheet when you scroll through the content.
   
   Click on the View tab towards the centre of the Ribbon.

3. Next click on Freeze Panes in the Window group which is found towards the right of the Ribbon.

   Then select Freeze Panes from the list that displays.

4. Click away from the row and notice a thin black ‘indicator’ line between rows 4 and 5, which shows the separation between the frozen and unfrozen parts of the spreadsheet.

5. Use the scroll bar at the right of the screen to move through the spreadsheet and notice how rows 1 through to 4 remain on the screen.

   Now freeze column A so it always stays visible.

   To begin to first click in cell B1. This is because you need to select the column to the right of the one to remain visible.

6. Note: Doing this now will result in the existing frozen row becoming unfrozen.

   If you wish to freeze both a column and a row you need to click on the cell that is both to the right of the column to be frozen and below the row to be frozen.

   For example to keep both column A and rows 1 & 2 visible you would click on cell B3 (column B – to the right of column A; row 3 – below rows 1 & 2).

   With cell B1 selected click on Freeze Panes in the Window group towards the right of the Ribbon.

7. Then select Freeze First Column.

   Click away from the selected column and use the scroll bar at the bottom-right of the screen to move through the spreadsheet to notice how column A remains on the screen.

8. To remove the frozen column, click on the Freeze Panes command.

   Then select Unfreeze Panes to unfreeze the column.

9. Click on Save to save the changes you have made.
CHANGING FONTS

The appearance that you choose for your text is referred to as the font or typeface. Font traditionally refers to a combination of typeface, style and size in points (e.g. Arial Bold 12 pt).

In Excel 2010 font just refers to the typeface or shape of the letters. Typical classic fonts include Times New Roman, Arial, Century Gothic and COPPERPLATE.

Follow these steps:

1. Before starting click on the Weekly Sales tab to display the Weekly Sales Workbook. Then use the scroll bar at the right of the screen to move to the top of the worksheet. Now click on cell A1 to select the main heading.

2. Click on the Home tab at the left of the Ribbon. Then click on the drop-down arrow next to the Font command (illustration below) in the Font group at the left of the Ribbon. The command will display a gallery of available fonts.

3. Point to different fonts and view the changes made to the main heading. This is Live Preview, which means you can view possible changes to your spreadsheet before making a final decision.

4. Scroll to and click on Comics Sans MS, or another font of your choice if you don’t have this one. This time the font formatting has changed in the cell and is no longer just a preview. It won’t change again unless you make another font selection.

5. Click on Save to save the changes you have made.
**Making Cells Bold & Italic**

One of the most common ways of emphasising data is to make it **bold** or **italic**. Bold data is darker in appearance because the letters are thicker, but it retains the same shape as normal data. Italic text is thinner and slanted to the right. Like all formatting features, cells must be selected before they can be made bold or italic.

Follow these steps:

1. We will now make the **Subtotals** under **Midweek** bold.
   Select the cells to affect by first clicking on cell **B12** and dragging to **G12**, to select the range **B12:G12**.
   Click on the **Home** tab at the left of the **Ribbon**.
   Next click on the **Bold** command (illustration below) in the **Font** group at the left of the **Ribbon** to make the text in the selected cells bold.

2. Now make the heading **Health Services** italic by using the **Mini toolbar**.
   This toolbar appears when you move your mouse over selected text. It has the same commands as the **Font** group (bold, italic, font style, etc).
   First click on cell **A3** to select the heading.
   Click in the selected cell with the **right** mouse button to display the **Mini toolbar** and the shortcut menu.
   Click on the **Italic** tool (illustration below) to italicise the selected cells.
   Notice that the shortcut menu disappears, but the mini toolbar remains as you hover over the selected range and goes away when you move away from the range.

3. Click in cell **A1** to deselect the previous range.

4. Click on **Save** to save the changes you have made.

![Image of text formatting steps]
CHANGING FONT COLOURS

The colour of text in cells can be changed, for example to reflect a corporate brand identity, to reflect the mood of the values in the worksheet, or just to jazz it up a bit. With colour, as with many of the other font formatting features, less is more – use too many colours and you will just confuse the reader.

Follow these steps:

1. We will now apply a Purple font colour to the cells B5 to G5. To begin click on cell B5 and drag across to cell G5.

2. Ensure that the Home tab is selected at the left of the Ribbon.

3. Then click on the down-arrow for the Font Color command (illustration below) in the Font group at the left of the Ribbon to display a menu of colours you can apply.

4. Hover the mouse pointer over different colours and notice how Live Preview displays the text in the selected cells in the various colours.

5. Click on Purple, which is the right-hand option under the Standard Colors heading in the bottom row of the menu to change the colour of the text in the selected cells to Purple.

6. Click on Save to save the changes you have made.
**Applying Borders**

Individual cells can be formatted with their own borders. Borders can also be applied to a group, or range, of cells. Borders allow you to draw attention to important cells in a worksheet that affect the totals, such as tax rates or percentage increases.

**Follow these steps:**

1. We will apply a border to cells **B5 to G5**, so before starting make sure you still have the range **B5:G5** selected.

2. Click on the **Home** tab at the left of the **Ribbon**.

3. Then click on the down-arrow for **Borders** (illustration below) in the **Font** group at the left of the **Ribbon** to display the available settings.

4. Select **All Borders** (6th option from top) to apply a border to all cells.

5. Click away from the cells to view the border.

6. Notice how the border is not slanted and it only borders the outside of the cells as a single group.

7. Click on **Save** to save the changes you have made.
**CHANGING BACKGROUND COLOURS**

To add more striking effects to your worksheets Excel allows you to change the background colours of cells and ranges. This is particularly useful for highlighting key data or placing emphasis on headings across columns or down rows. In Excel jargon when you change the background colour of a cell you are changing its *fill* colour.

Follow these steps:

1. We will now change the background colour of cells B5 to G5. To begin this click on cell B5 and drag across to cell G5 to select the range B5:G5.
2. Click on the down-arrow for the Fill Color command (illustration below) in the Font group at the left of the Ribbon to display a menu of colours you can apply to the background of the cells selected.
3. Hover the mouse pointer over different colours and notice how Live Preview displays the background in the selected cells in the various colours.
4. Click on Yellow which is the 4th colour from the left under the Standard Colors heading in the bottom row of the menu to change the colour of the background. Then click away from the cells to view the change.
5. Click on Save to save the changes you have made.
CREATING ABSOLUTE REFERENCES (1)

There will be times when you need to create a formula which references a cell (or cells) that must remain the same even when it is copied around the worksheet (e.g. cell A1). That is, you will need to make the reference to that cell an absolute reference. A cell reference in a formula is made absolute by preceding with a $ sign its column coordinate (e.g. $A1), its row coordinate (e.g. A$1) or both (e.g. A$1).

Follow these steps:

1. We are now going to investigate absolute referencing in formulas. Before starting click on the Shop Sales worksheet tab at the bottom of the screen.

We need to enter a formula into cell D9 to calculate the value in cell C9 plus 45%. However, it is considered bad practice to enter the 45% directly into the formula. This is because when it needs to be changed you have to do so in every formula that includes it, which is time-consuming and error-prone. We will therefore use what is termed a centralised variable, which in this case is cell B4.

2. To create the formula click on cell D9 and enter =C9+C9*B4 Then press the [Enter] key on the keyboard to accept the change.

3. We now need to copy this formula to cells D10 to D15.

So click on cell D9 again and then copy the formula by moving the mouse pointer to the fill handle at the bottom-right corner of the cell (illustration below) so that the mouse pointer appears as a thin black cross. Then drag the mouse pointer down to cell D15 to fill the cell range with the formula.

4. You should notice that some cells display the #VALUE! error message (illustration below) whilst others do not complete the calculation.

To investigate the reason for this click on cell D10 and view the formula in the Formula bar below the Ribbon.

You should notice that the formula references cell B5 and not B4, the centralised variable that we intended.

This change, from B4 to B5, was the result of Excel’s use of Relative referencing, where cell references are increased as you drag the fill handle down or across.

To deal with this we need to change the reference to cell B4 so it is an Absolute reference, and so doesn’t change when copied using the fill handle.

5. Click on Save to save the changes you have made.
CREATING ABSOLUTE REFERENCES (2)

A cell reference in a formula is made absolute by preceding with a $ sign its column coordinate (e.g. $A1), its row coordinate (e.g. A$1) or both (e.g. $A$1). You can either enter the $ sign(s) manually, or by selecting the formula to be modified and then using the [F4] key on the keyboard (which cycles through the four options).

Follow these steps:

1. Before starting ensure that you have completed the previous page and that you are still viewing the Shop Sales worksheet.
2. To modify the formula so that it has an absolute reference to cell B4:
   - First click on cell D9.
3. Then, in the Formula bar below the Ribbon, drag over the B4 reference and enter $B$4 to make the formula read =C9+C9*$B$4 (illustration below).
   - Press the [Enter] key on the keyboard to complete the change.
   - Note: $B means always refer to column B; $4 means always refer to row 4.
4. Copy this formula to the other cells by clicking on cell D9 and using the fill handle at the bottom-right corner of the cell to copy the formula down to cell D15.
5. You should see that the calculation has now worked correctly for all of the cells, and if you view each cells’ formula, they references to cell B4.
6. Finally, test the centralised variable by clicking on cell B4 and overtyping the 45% with 20%.
7. When you press the [Enter] key on the keyboard you should see the values in cells D9 to D15 change (along with other cells that reference these cells).
8. Click on Save to save the changes you have made.
INSERTING, Deleting, and Renaming Worksheets

Once you’ve settled on a structure for your workbook, you may find that you have some worksheets that can be deleted. Alternatively, you may find that you need additional blank worksheets inserted.

However, users beware: deletion of worksheets is permanent and cannot be undone; so save your workbook before making these changes.

Follow these steps:

1. To create a new worksheet click on the Insert Worksheet icon. This icon is located at the right of the worksheet tabs (illustration below). A new worksheet is inserted and by default named Sheet1.

2. It is easy to rename a worksheet tab to give it a more meaningful name. In this case we will rename the Sheet1 tab to temp.

3. To do this right-click on the Sheet1 tab. Then select Rename from the list that displays.

4. With the Sheet1 tab highlighted with a black background type the new tab name, which in this case is temp. When you have finished press [Enter] on the keyboard to record the change.

5. You can also delete unwanted worksheets. To delete the temp worksheet right-click on the temp worksheet tab to display the shortcut menu. Select Delete to remove the worksheet.

6. As the worksheet contains no data, the worksheet is deleted immediately. If it had contained data, Excel would ask you to confirm that you do wish to delete the worksheet.
MOVING AND COPYING A WORKSHEET

Moving a worksheet refers to the process of changing the order of the worksheets in the workbook. There are times when you may want to reorganise the worksheets in a workbook to match the business hierarchy, or to retain a chronological order. Worksheets can be dragged into position, one or more at a time, or moved via the Move or Copy dialogue box.

Follow these steps:

1. We will begin by moving the International Revenues worksheet to before the Revenue worksheet by using the drag method.

   To do this click on the International Revenues worksheet tab at the bottom of the window.

   Then, with the mouse button still depressed, drag the tab to the Revenue tab.

   As you do this a black downward facing arrow appears showing where the tab will be relocated to (illustration below).

   When the black downward facing arrow appears between the Shop Sales and Revenue tabs release the mouse button to complete the move.

2. We will now move the International Revenues worksheet to before the Weekly Sales tab using the Move or Copy dialogue box.

   To begin click on the International Revenues tab.

   Make sure that the Home tab at the left of the Ribbon is selected.

   Then click on Format in the Cells group at the right of the Ribbon.

   Select Move or Copy Sheet from the menu that displays.

3. Ensure that Weekly Sales is selected in Before sheet:

   Then click on [OK] to complete the move.

4. We will now create a copy of the worksheet so that it appears before the International Revenues tab.

   Instead of using the Format command, this time right-click over the International Revenues tab

   Then select Move or Copy… from the menu that appears.

   Ensure that International Revenues is selected in Before sheet:

   then state that you want to create a copy by placing a tick next to Create a copy.

   Click on [OK] to complete the copy process.

   A new tab will appear, International Revenues (2), with the (2) indicating that this is a copy of the worksheet.

5. Click on Save to save the changes you have made.
**Finding and Replacing Text**

Common reasons to found text in a worksheet are because you want to locate an entry that you know exists, or because you want to replace an entry with new data. A *Find* operation in Excel requires you to specify the text, value and/or format that you want to search for. Excel will search the active worksheet then select the first cell that matches the criteria.

Follow these steps:

1. Before starting click on the *Shop Sales* tab to view the *Shop Sales* worksheet.
2. Click on the *Find & Select* command (illustration below) on the *Home* tab in the *Editing* group at the right of the *Ribbon* to display the menu. The menu includes a series of options for locating specific types of data or cells in the worksheet.
3. Select *Find* to display the *Find and Replace* dialogue box.
   - Type *broadband* into the *Find what*: panel.
   - Then click on [*Find Next*].
4. The cell pointer will jump to the first cell that contains matching text. Notice that Excel does not worry about the text’s case and, by default, looks for the text even if it is only part of a cell entry.
5. Click on [*Find Next*] again to find the next occurrence of *broadband*.
   - You can also use this facility to replace text.
   - To do this select the *Replace* tab in the *Find and Replace* dialogue box.
   - Type *Network* in the *Replace with*: section.
   - Then select [*Replace*] to replaces *broadband* in the selected cell with *Network*.
   - **Note:** if you wanted to replace all occurrences you would click on [*Replace All*].
6. Click on [*Close*] on the *Find and Replace* dialogue box to close it.
UNDERSTANDING CELL ERROR VALUES

Excel displays an error value in a cell when it cannot calculate the formula for that cell properly. Error values always begin with a number sign (#). The meanings of the most common error values are explained in the following table:

1  ######  This shows that the number is too long to fit into the cell. Widen the column to accommodate the number.
2  #NAME?  This occurs when Excel does not recognise a name in the formula you have entered.
3  #DIV/0!  This appears when you have attempted to divide your content by the number zero or by a cell that contains no value.
4  #REF!  This occurs when you refer to an invalid cell address or a deleted cell. It most often occurs when you delete or paste over a cell referred to in a formula.
5  #NUM!  This indicates a problem with a numeric value, such as a number that is too large or too small to be represented by Excel, or a formula that cannot be calculated, such as the square root of a negative number.
6  #N/A  This indicates that no information is available for the calculation you want to perform. You can enter #N/A in a cell yourself to indicate that you are awaiting data. Any formulas that reference cells containing the #N/A value return #N/A.
7  #VALUE!  This appears when the wrong type of argument, or data type, has been used for a function. For example, it can occur if you try to add the contents of cells that contain text, not numbers.
**SORTING DATA INTO ORDER**

Microsoft Excel allows you to sort worksheet data alphabetically, numerically or chronologically. You can sort your data by columns, starting from the highest value working down to the lowest (descending), or from the lowest value working up to the highest (ascending). Sorting data can help to analyse trends in sales or target areas in business, and also to make comparisons between data.

Follow these steps:

1. Before starting ensure that the Shop Sales worksheet is displaying.

   We will sort the Net Profit data for the Electronics category into order so that the most profitable is displayed first.

2. Therefore begin by selecting cell G19 and dragging down to cell A23 so that the range A19 to G23 is selected.

   Notice that the first cell selected, G19, is not highlighted like the other selected cells. However, it has been selected!

3. The reason G19 is not highlighted is because it has been defined as the first cell in the selection. Hence when the sort is performed, Excel will use the contents of this cell as the basis for the sorting function.

4. Ensure that the Home tab at the left of the Ribbon is selected.

   Then click on the Sort and Filter command (illustration below) in the Editing group at the right of the Ribbon to display a menu of options.

5. As we wish to display the most profitable items at the top of the list, select the Sort Z to A option.

   You should notice that the most profitable item (5,676.00) is now displayed at the top of the list, and the least (812.50) at the bottom.

   **Note:** When performing a Sort it is important to include all the relevant data in your selection so that relationships between the data are not lost.

   This is why we included the range G19 to A23, so that the Catalogue No and Model data was kept with the relevant Wholesale and Net Profit (etc.) figures.

   If you do not do this where relative data may exist, Excel will display the Sort Warning dialogue box asking whether you wish to expand the selection.

6. Click on Save to save the changes you have made.
**COMPARE WORKBOOKS SIDE BY SIDE**

You can quickly view two worksheets in the same workbook or in different workbooks by viewing them side by side. This is a helpful skill to master if you ever need to compare Excel worksheets. Instead of moving from one open workbook to another, you can use the View Side by Side command to view two workbooks at the same time.

**Follow these steps:**

1. Before starting click on the Revenue tab to view the Annual Revenue 2009 worksheet.
2. To begin the steps to compare workbooks side by side, first click on the View tab towards the centre of the Ribbon to view its commands.
3. Click on New Window in the Window group at the right of the Ribbon to open a copy of the workbook we are using. This will enable the two workbooks to be viewed side by side.

   While we are still viewing our original workbook, click on the View Side by Side command (illustration below) in the Window group at the right of the Ribbon. This will place the copy of our workbook above our original in order to view both at the same time.
4. Click on the Weekly Sales worksheet tab in the top workbook.
5. Click on the International Revenues worksheet tab in the bottom workbook in order to learn how you can navigate within both workbooks easily this way.

   To change the display so that the worksheets are side by side:
   - Click on the Arrange All command (illustration below) in the Window group at the right of the Ribbon.
   - Click on the Tiled option button in the Arrange Windows dialogue box that displays.
   - Click on [OK] to reposition the two worksheets.

   To return to displaying one worksheet:
   - Click on the (right-hand) International Revenues worksheet to make it the active worksheet.
   - Click on the grey Close button at its top-right corner.

   **Note:** if you had two workbooks already opened you would not need to click on New Window because the View Side by Side command would already be activated and ready for use.
SETTING ROWS AS REPEATING PRINT TITLES

If you have a long list of data to print, it can be pretty confusing by the time you get to the third page if you can’t remember what each of the columns refers to. To make it easier for you to interpret printed data, Excel allows you to set a row or rows as print titles that are repeated at the top of every page. This enables, each column to have its own heading no matter which page it is on.

Follow these steps:

1. Before starting ensure that Revenue worksheet is displaying. Begin by performing a Print Preview of the worksheet. To do this click on the File tab at the top-left of the window.
2. Then click on Print. This new view in Excel 2010 displays the Print options on the left and the Print Preview on the left, and replaces the separate Print and Print Preview views of previous versions.
   If you use the Preview panel on the right to scroll through the two pages you should notice that page 2 does not display the column headings, which makes viewing the pages harder and could cause confusion.
3. When you have finished click on the Home tab at the left of the Ribbon. To begin adding the column headings that appear in row 4 first ensure that you can see row 4 on screen.
4. Then click on the Page Layout tab toward the left of the Ribbon. Click on the Print Titles command found towards the centre of the Ribbon.
5. The Page Setup dialogue box will open with the Sheet tab selected. Click in the Rows to repeat at top: panel to obtain an insertion point.
6. Now click on the row header number for row 4. This will insert the reference $4:$4 in the panel (illustration below).
7. Click on [OK] to return to your worksheet.
8. You will probably notice that the worksheet does not appear changed from before setting up the repeating row.
9. Click on Save to save the changes you have made.

Now perform another Print Preview of the worksheet by clicking on the File tab at the left of the Ribbon.

Then click on Print. You should notice in the Preview panel on the right that the column headings (London, Dublin etc.) now appear on both pages.
When you have finished click on the Home tab at the left of the Ribbon.
**PERFORMING A PRINT**

The **Print** option under the **File** tab enables you to print preview and then print your worksheet. There are a range of options within the left-hand Print panel which enable you to specify, for example, the printer and number of copies to be printed.

**Follow these steps:**

1. Click on the **File** tab at the left of the **Ribbon**. Then Select **Print** to view a list of printing options on the left and the new Print Preview on the right.

2. There are many printing options available to you. For example:
   - Under the **Printer** heading can specify what printer you wish to use;
   - In the **Pages**: panel under the **Settings** heading you can specify which pages are to print;
   - Immediately under the **Settings** heading you can specify whether the Active sheets(s), a selection, or the entire workbook is to be printed;
   - In the **Copies**: panel at the top of the window you can state how many copies are to be printed.

3. When you are ready to print you would click on the **Print** button at the top of the window. However, we do not want to print this spreadsheet at this time. Therefore, click on the **Home** button at the left of the **Ribbon** to return to your worksheet.
CLOSING A WORKBOOK & EXITING FROM EXCEL

When you have finished working with Excel and no longer need to have it available you should exit in the proper manner. This can be done in several ways which include using the menus and the Close button. If you exit Excel without saving your work or naming the workbook a message box will appear prompting you to do so.

Follow these steps:

1. Click on the File tab at the left of the Ribbon. Click on [Save As]. The Save As dialogue box appears.
2. We will use the Save As option here in order to save the workbook under a new filename, and thus create a backup copy.
3. In the File name: panel type Global workbook Then click on [Save] to save the workbook with this new filename.
4. To close Excel first click on the File tab at the left of the Ribbon. Then select [Exit]. You are not prompted to save changes to any workbooks because you already have done so.
SESSION EVALUATION

If you have completed this session as a taught session, we would welcome your feedback to help us to improve our training provision by completing a short online Session Evaluation.

To access the Evaluation from any Open-Access PC:

1. Click on the Start button to open the Start Menu.
   Click on All Programs to cascade the Programs menu

2. Click on Training to display the Training subfolder.
   Select Session Evaluation.

3. The short online Session Evaluation will display ready for you to complete. This should take no longer than a couple of minutes.